WebGPU not working

Hi guys ( I hate this),

Sorry before hand if this is already acknowledged but WebGPU has been broken for a while now ( at least 2 to 3 months back).
I “know” this is not a BabylonJs issue, because this happens even with the previous versions.

About a month ago all my projects and demos stopped working with WebGPU ( Chrome, Edge, Chrome Canary). I ran some PG’s and saw the same. I assume this is related to Chromium updates on spec or something.

To replicate this just open a PG like the one bellow, select WebGPU and you’ll notice there is no textures being loaded.

Some examples of PG’s from the docs:

Thanks for reading this team. Have a great one!
Cheers! :innocent:

Everything works for me as expected in WebGPU, in both Chrome and Edge.

Do you have some errors in the browser console? What does this page display for you:

1 Like

I am in Windows 11 (Surface Pro 7) - Chrome canary 127.0.6504.0 (Compilação oficial) canary (64 bits)

I see this:


Oh hell no… I have another Surface Pro running Windows 10 and … it works… Now what!?
Not a bug in BabylonJs as I suspected. :crazy_face:

1 Like

Probably a problem with the drivers of your GPU. Have you installed the latest version?

This is definitely a drivers issue. :cold_sweat: not a BabylonJs issue :heart_eyes:

Although I’ve updated the MS drivers for Surface Pro 7 (https://www.microsoft.com/en-us/download/details.aspx?id=100419) no luck… Thank you for W11 I am loving it… :disguised_face:

Got the latest drivers directly form Intel: https://www.intel.com/content/www/us/en/search.html#sort=relevancy&f:downloadtype=[Drivers]&f:@tabfilter=[Downloads]&f:@stm_10385_en=[Graphics,Processor%20Graphics,Intel®%20Iris®%20Plus%20Graphics%20Family] … no luck either :sweat_smile:

Going to be locked on WebGL on this device… I just hope MS and Intel solves it somehow. I love my Surface. :crazy_face:

I know I am hammering this one down but… I found this on Bevy engine and can relate to the fact that they solved it. This seams to be related to the selection of the gpu.adapter… :face_with_raised_eyebrow:
As I am using Windows 11 it does not always fallback to DX12 as it uses Vulkan by default.

Related investigations on some open discussions about this:

Cheers! :sunglasses:

Unfortunately, I don’t think you can choose the backend for WebGPU in Chrome (contrary to WebGL where you can change the ANGLE setting in the chrome flags) :frowning:

Yeah I suspected so.
I was looking into the Bevy demos using WebGPU and they have this working somehow. :thinking:

I see this in their logs:

WARN crates/bevy_pbr/src/ssao/mod.rs:86 ScreenSpaceAmbientOcclusionPlugin not loaded. GPU lacks support: TextureFormat::R16Float does not support TextureUsages::STORAGE_BINDING.

In my GPU Internals (chrome://gpu/) I have:
Graphics Feature Status

  • Canvas: Hardware accelerated
  • Canvas out-of-process rasterization: Enabled
  • Direct Rendering Display Compositor: Disabled
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • OpenGL: Enabled
  • Rasterization: Hardware accelerated
  • Raw Draw: Disabled
  • Skia Graphite: Disabled
  • Video Decode: Hardware accelerated
  • Video Encode: Hardware accelerated
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated
  • WebGPU: Hardware accelerated
  • WebNN: Disabled

If the problem was because we use unsupported features by WebGPU, we would have some warnings / errors in the browser console log.

This is expected on a Windows computer. I have the same:


For this PG:

Can you report what you get in the browser console log (the full log)?

No errors in the log related to WebGPU :thinking:

I’m afraid I can’t help you any further…

[…] I just tested with the latest version of Firefox nightly, it seems their WebGPU support has improved and https://playground.babylonjs.com/#5ZCGRM#4 does work (there are some warnings in the console log but the display is ok)! So, maybe you can try it and see if it works for you.


No worries. It all works on other hardware I own. :crazy_face:

Thank you for your efforts. I appreciate it. I just wonder how many users may be affected by this… but probably not many. Well time to move on to other stuff.

As closing note. Lessons learned. Do not update to Windows 11 on Surface Pro 7 if you want to use WebGPU with BabylonJs :grin:

1 Like

Yeah I’ve tested with Firefox Nightly and it worked. Thank you!
Let’s just hope whatever is causing this issue get’s fixed on MS Edge and Chrome. :sunglasses:

1 Like