Babylonjs not working on Chrome 108.0.5359.94

Hello community! I found strange issue, in my chrome any of babylon based project not worked, even a playground examples from main page.
First of all i went to about:flags and check WebGL, then about:gpu in results all enabled and works.
Then i went to Threejs examples and to my surprise it works.
Attached archive with reports.
My hardware - Laptop MSI katana with Intel 11800H, GeForce 3060ti
OS - Kubuntu 22.04LTS;
Maybe anyone know how can i fix it? (1.2 MB)

Ohhhhh that sounds pretty bad… @Cedric or @bghgary do you have a ubuntu to test on ???

Would be great if anybody else in the community can try ?

webgl not supported means a simple canvas.getContext(“webgl”, options) is not working so one of the options is breaking it but which one is the issue…

I only have Ubuntu in a VM, but the playground is working with Chrome for me.

Google Chrome	108.0.5359.94 (Official Build) (64-bit) 
Revision	713576b895246504ccc6b92c2fb8ce2d60194074-refs/branch-heads/5359_71@{#3}
OS	Linux
JavaScript	V8
$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.5 LTS
Release:	20.04
Codename:	focal

@deslancers would be great if you could report on the chromium bug tracker and check if mozilla is having the same issue ?

I have this issue a few weeks, currently i work and test my projects in mozilla without any issues, this bug i found in last updated chrome. I’ll create report on bug tracker.
Also i tested chrome the same version on Windows 11 and it works fine. Looks like problem with linux package.

yup and not all dist as ubuntu LTS seems to be doing okay :frowning:

I rollback chrome to 106 and now all works fine!

1 Like

so definitely seems on their hand unfortunately :frowning:

Try to disable the Vulkan backend here: chrome://flags/#enable-vulkan

It seems like the Intel Vulkan drivers are causing this issue (which would also mean that you are not using your NVIDIA GPU, but the i-GPU instead).

1 Like

Well, it’s complicated.
It seems like Chrome started using the Vulkan backend if available (since about 107) and in the case of an Intel iGPU this seems to be broken. The root cause would then be a faulty Intel driver… or its integration which would then be Google turf again. :thinking:

Most likely related to this issue:


Thanks for the info @7om hope they can address those issues soon.

1 Like

HI! I disable Vulkan in Chrome and now it works as expected, thank you!