Webm video alpha channel not working in Google Chrome


I am playing webm video in my 360 dome, the alpha channel seems to not work in Google Chrome. It works well in Firefox. Do I have to add anything in code to overcome this issue?


Adding @RaananW for help.

Any luck on overcoming this problem?

Not sure I follow. Both videos look the same in both firefox and chrome. What versions are you using, and what would you expect the result to look like?

This link here shows very different video on Chrome and Firefox. Only on firefox, it plays exactly like it should be (with alpha channel). The chrome version is Version 90.0.4430.212, which is the latest.


Want to share a screenshot of what you are seeing?

What happens when you open the file using the browser directly? does it respect the alpha channel then?

BTW - a different result between two browsers is usually something we can’t help with. The video texture is using the basic browser functionality (video decoder, canvas updating).

I tried adding the video directly to the chrome browser and it plays well. Exactly like how it should be. But only in Babylon.js, it causes this issue. Maybe due to missing codec or incompatibility?
Here are the two screenshots:



That’s my chrome…

Anyone else can reproduce that?

So weird! I am using the latest version of chrome on windows 10.

I tried on both edge (*chromium), latest chrome (90) and latest canary (92), all work correctly

Okay :sweat_smile: I just tried on two computers with me. It works perfectly on firefox but both Edge and Chrome shows this problem :sweat_smile:

Sorry, it’ll be very hard for me to check if I cannot reproduce it…
If anyone else experiences this, please write here.

I have the same in Chrome and Edge

Meanwhile the file itself opens with no problem

Firefox and Opera work fine

Thanks for reproducing it. Could this be PC related?

It should be related with something, but I cannot understand the relationship :slight_smile:
Tested with latest Chrome on Mac, works perfect.

okay then it is definitely to do with PC.

You should try to report it to Chromium

1 Like