WebXR in HTC Vive using Windows 10, SteamVR, Firefox and Polyfil


I tried to run my project on Windows 10, SteamVR, Firefox and Polyfil.

First enter immersive VR session:

  • I can click the immersive-vr button but in the goggles I can only see the image for each eye as 2d planes. The canvas in web browser shows that the areas for each eye fill only part of the canvas (lower left portion).

Then I exit and re-enter without reloading the page and everything seems to work. The canvas in browser is properly filled by areas for each eye.

This page works normally with firefox xr device emulator and Oculus Quest.

I am running 4.2.0-alpha.12

Side note: Chrome XR does not seem to work with HTC Vive even with Steam Beta and Latest Chrome Canary. The device is just not available all though WebXR samples state that browser supports XR:

Kind regards,

ping @RaananW

Hi Tommi,

It feels like either us or the polyfill don’t resize the canvas correctly. As it does work after the 2nd attempt.

I have to say that I don’t have a lot of experience with the polyfill. It should work correctly, but I don’t know what fallbacks they used there for each XR functionality, so it is hard to say what the problem is.

I will run some experiments with firefox and the polyfill. Just need to find the time for that

1 Like

Thank you RaananW



I am experiencing this same problem with valve index, latest firefox, steam (not beta), babylonjs 4.2.0-alpha.32 and “webxr-polyfill”: “2.0.3” but even after second try the vr does not start working. How ever the web xr example works correctly: Room Scale

Kind regards,

I sadly don’t have a valve index, and can’t quite test the exact setup.
Have you tried firefox’s native webxr support? does it work with it?

Can you share a sample that doesn’t work? with the polyfill or without?

So! Installed Steam + SteamVR to check - with the flag enabled I can enter WebXR experiences on firefox (checked using a windows MR device, but it should be the same on the vive)

Thank you. Disabling the polyfil I could get the setup working with, firefox, firefox nightly and chrome canary. Chrome canary has good resolution and refresh rate but for some reason firefox and firefox nightly have low resolution (can see pixels very clearly) and slow refresh rate. Any ideas what could be causing this behaviour on firefox and how to fix it?

Kind regards,

Yeah, I experience the same.
I still try to understand why it happens. If you want to add a ticket to github so you can follow my progress please go right ahead. I will make it as investigation and make sure to keep you updated there.

Thank you and sorry about delayed response. Here is the ticket:

Hi, just wanted to update - I can’t reproduce this on my device, but I don’t have a valve index. care to share the experience? screenshots/video recording of the experience will be very helpful.