White blinking on Samsung


#1

Hello everyone
I created a car game and its working great on all devices and browsers besides on samsung internet browser I have a weird bug my simple low poly car model is blinking white all time with some interval of time (not all model just some of faces) at least on Samsung S6, S7, Galaxy Pad, J3, J5, J7.
for all mobile devices i disableWebGL2Support = true
models i used is .obj format with .jpg textures with one mesh

maybe some one have the same or similar bug and you can help me

bug


#2

Hello Jon… welcome to the BJS forum.

For a test… please try:

light.specular = BABYLON.Color3.Black();
carMaterial.specularColor = BABYLON.Color3.Black();

Please report any changes seen. Thx!


#3

HI Wingnut thx for quick answer.
i tried your changes and it still blinking.
but if i set scene.clearColor = BABYLON.Color3.Green().toColor4();
my car now blinking green)))


#4

Hi again. Interesting find. Thx for testing that stuff.

I’ve done a LITTLE bad research, so far. Let’s hope smarter people comment soon.

Things I have found:

Somewhere, someone said… set: engine.getCaps().highPrecisionShaderSupported = false; (as a test)

Another said try: var engine = new BABYLON.Engine(canvas, true, {disableWebGL2Support: true });

Another said… please send us the output of: alert("engine.getGIInfo(): renderer: " + engine.getGlInfo().renderer + ", vendor: " + engine.getGlInfo().vendor + ", version: " + engine.getGlInfo().version); (from one of the devices that has “blinking white” problem)

The more info we can gather about the capabilities/OS versions… for devices which show the ‘blinking white stuff’, the more chance someone can tell us WHY it happens.

Only one thing found on the web… an older post about Pixi.js. link. They seem to mention: PIXI.glCore.VertexArrayObject.FORCE_NATIVE fairly often, but I don’t know if there is a similar command… for BabylonJS.

I found these things… by searching the web, and searching the old forum for ‘Android’ link and ‘Samsung’ link. There are many returns for both of those searches, and I have only STARTED browsing the returned titles and content. You may wish to do more of that.

I’m not sure what else to try, but I have low experience in this subject. Stay tuned for more/wiser comments. If you discover more, please tell us. THX!


#5

Hi
i set engine.getCaps().highPrecisionShaderSupported = false; and no changes
disableWebGL2Support: true was already true for all mobile devices
and i set PIXI.glCore.VertexArrayObject.FORCE_NATIVE to true because i use PIXI for 2d GUI
and here is alert
alert%20j7


#6

and here is alert
alert%20s7


#7

Ok, thanks JD! Well done.

I guess we just continue to listen for wise comments, now.

It IS interesting that the mesh flashing color == scene.clearColor. hmm.

If you do more experiments and/or learn more, please tell us, here. thx.


#8

Looks like an issue with alpha.

Are you using highligh layer? or glow layer? Can you turn off alpha just in case with BABYLON.StandardMaterial.OpacityTextureEnabled = false ?


#9

HI Deltakosh no i am not using highligh or glow layer
i tried OpacityTextureEnabled = false and nothing hapens its still blinking


#10

Can you share your scene on the PG?


#11

hi again
here is a simple PG with my code and blinking not only model
simple cube mesh too

to rotate “car” click on the left or right side of scene
https://www.babylonjs-playground.com/#BEFOO#334


#12

Well obviously it works on my pixel 3.

Some ideas:

  • remove the freeze()
  • remove checkReadyOnlyOnce = true
  • remove needDepthPrePass

#13

hi sorry for suuuuuuuuuuuuuuuuper late response
i apply all your ideas and set scene.clearColor = new BABYLON.Color4(0, 0, 0, 1);
and its works for me thank you very mush))


#14

Glad it worked :slight_smile: