[XR]Ray's angle is not correct

I’m using Oculus RiftS on my PC
I’ve tried all of the sample demos, but like the screenshot, the pointer? Ray? I don’t know the exact name of this one, but it has no normal angular output, and it’s being output upward to the controller.
Do you plan to fix this, or is there a way to specify the property?
I looked at the documentation for a few hours and I didn’t discover it.

I tried several times to create an account a few hours ago to ask here, but nothing was done because all account creation functions were disabled at https://forum.babylonjs.com/. At first I wondered if this site was no longer active.
So I went to github and posted my question here

==> Please open a thread on the forum first :slight_smile:

Funny, creating an account was made possible after seeing this message

Hello and welcome

And thanks for posting the question here :slight_smile:
adding @RaananW our XR master


The pointer selection feature (the rays you are seeing) is defined using information from the headset itself. Unless you parented the XR component (which you shouldn’t), it should point to the location your headset expects “front” is. It is different from headset to headset.

When looking at your screenshot, it seems like the model is a bit off. are you using the online repository, or the models defined internally by babylon? can you show me a project or a reproduction of the issue?

I am using the model defined by babylon
This problem can also be reproduced in the following samples, for example

Also, the controller model of RiftS is outdated as shown in the sample
So I specify the controller model in my project
inputSource.onMotionControllerInitObservable.add((webXRController) => {
webXRController.profileId = “oculus-touch-v2”;
console.log(“Added motion controller:”, webXRController);

Have you tried the reposidory instead? I just want to be sure it is an internal issue with our models and not an overall issue with the controller update.

To force a specific model you will need to define it prior to loading the models (using the WebXRMotionControllerManager)

The playground you pasted works for me -

But this seems to be some default playground from the docs, isn’t it?

The WebXR API Emulator does exactly what you posted in the image
But if you use RiftS, it’s exactly as I just posted (the controller coordinates are correct, only the rays are different)
I’m going to use WebXRMotionControllerManager, but I don’t know how to use it in plain JS (because I can’t use import).
I don’t think this is going to fix it, since the default model will be the right angle in Quest to begin with.

I’ve also tested it on the following site (this is Threejs though…)

I switched the controller model at
RiftS didn’t seem to support it.

I don’t have a riftS to test with, but this is the first time I hear about a problem with the online repository and RiftS models loaded incorrectly.
This seems to be an issue with the input-repository, if the input profile viewer does the same.
I will keep an eye on rift-S issues

RiftS and Quest use the same controller, but these devices have different coordinates, as they do in Unity, I’m guessing that’s the problem that’s happening.
Honestly, I don’t know if I need to solve it too much since Quest2 is being released.

I have found a similar problem, perhaps he is using RiftS.
I’ll try to address it somehow.
1 Like

So sorry, I wish I could test it with you. I have an old rift that works well and a quest that works well…

If you want to provide some transformation that should be applied to a rift controller, I will be very happy to add it to our model loader to make sure riftS users are being addressed correctly.

1 Like

Just as an update, today I got WebXR working through Chrome with my original-generation Oculus Rift for the first time (using Oculus’s beta runtime and some reg-keys, of all things) and immediately repro’d this problem. Afterward, trying to quit the immersive app took down my whole Chrome instance. It looks like the support for the Oculus WebXR path through Chrome on desktop is very shaky right now. As much as I’m looking forward to being able to edit my Playgrounds on a virtual desktop and thus have an entirely in-HMD dev loop, I don’t think the Rift runtimes are quite ready for that yet. :slight_smile: