A Low-Poly Creation

When I started using Blender 2.8, I had a little trouble - which seemed to relate to a number of issues that included, in no specific order: 1. getting past right clicking to Select things, 2: finding out where stuff had been hidden, 3. new names for functionality, 4. my age and instincts, 5. buggy versions that I seemed to download (finally using Blender 2.81a).

Anyway, to solve these issues a started following YT tutorials and ran across a gentleman called Grant Abbitt who has quite a few Blender 2.80 tutorials, and is a teacher and freelance Blender artist. Chatting with Grant, led him to send me a file from a series of YT videos about creating low poly game models. This I converted for use with BJS :

*** Don’t use this link as there seems to be a timing issue with Chrome ***

Both links should now work in Firefox and Chrome. The first one I have now added a viewable title and an fps box. Hope to add more -soon!

The Bridge

Try this instead - now same as above but no title, and fps box

Bridge 2

It uses instances for plants and the parts of the bridge, and backface culling is turned off for the plants.

The textures are large, and could easily be reduced, but were hand painted by Mr. Abbitt so I left them alone for now.

cheers, gryff :slight_smile:

9 Likes

I get this error in Chrome:
image

It does work in Firefox: very nicely done!

Regarding the error in Chrome:

It must be an asynchronous problem somewhere, as sometimes I only see the grass, and some other times (after refreshing), I can see the grass + water. One time I saw grass + water + bridge.

Thanks for the report @Evgeni_Popov. It works fine in Firefox, as you say, and worked fine in Chrome on a Samsung S4 phone.

Any suggestions about what the issue might be - I am not the world’s best coder :wink:

cheers, gryff :slight_smile:

I get your error message In Windows 10/Chrome(v79) too - but it works sometimes when I hit the refresh button … ? (see image below)

All thoughts welcome …

cheers, gryff :slight_smile:
bridge

Unfortunately, such bugs are hard to find with a repro, but without one it does seem just impossible…

The getAttributeLocation method is from the effect class:

public getAttributeLocation(index: number): number {
        return this._attributes[index];
    }

So this._attributes is undefined when the bug pops up.

This property is set in the callback function called by engine._executeWhenRenderingStateIsCompiled (which itself is called in Effect._prepareEffect).

So it seems we end up calling getAttributeLocation too early, before engine._executeWhenRenderingStateIsCompiled has been able to call the callback.

A wild guest is that _renderWithInstances calls bind too soon, before the effect has been fully setup / is ready…

Digging a bit:

In Mesh.render, we have:

if (material._storeEffectOnSubMeshes) {
    if (!material.isReadyForSubMesh(this, subMesh, hardwareInstancedRendering)) {
        return this;
    }
} else if (!material.isReady(this, hardwareInstancedRendering)) {
    return this;
}

If material._storeEffectOnSubMeshes is false, we check material.isReady() instead of isReadyForSubMesh().

But isReady() just returns true.

So, try to see if _storeEffectOnSubMeshes is false for some of your materials, and if yes it could be a clue to find the problem.

2 Likes

TY @Evgeni_Popov . I had figured out it was some kind of timing issue (particularly those large textures) - so I started hacking with the code.

Anyway try this - works in Windows 10/Chrome and Firefox for me Bridge2.

As I don’t have a phone right - not tried it in Chrome on the Samsung 4.

Hope you see some improvement

cheers, gryff :slight_smile:

Too bad you really need a wnidows or maybe OSX tablet to do workable hand painting. My tablets are not going to run Blender (Android & iOS). At least, that’s going to be my excuse.

Seems like this is a good use of std materials. Would be interesting to see what a PBR export, with the studio env looks like, if you have the time.

BTW, saw stuff in the first 30 seconds of tutorial, I did not know.

1 Like

@JCPalmer : Well I will see where it goes, Jeff. I had one of my network computers crash - still trying to dig my way out of that

Well he does some good tutorials, as I have said before, though he tends to spend a lot of time on painting and sculpting (which can be quite hi-poly). So I thought he might like a bit of promotion :slight_smile:

As for the tablets, he has quite an expensive one I think.

cheers, gryff :slight_smile:

Yes, it does now work in Chrome for me!

1 Like

@Evgeni_Popov : TY for your suggestions … and glad it now works :slight_smile:

Now for a little cleanup - coding never seems to end :neutral_face:

cheers, gryff :slight_smile:

1 Like

That’s why we love it ;D

1 Like

Some people do. To me it just gets worse - different browsers, OSs, devices of all kinds. From mice to fingers, and screens of all kinds.

Seems like a short road to the madhouse sometimes :grin:

cheers, gryff :slight_smile:

1 Like

Nice tiny scene :slight_smile:

Did you made the texture painting right inside Blender?

Little feedback:

  • I noticed space chars in texture file name :scream:
  • is the island border edges using sharp shading? it looks smoothed and maybe made them sharper could looks great? (don’t know)
  • I think playing a bit with water specular could add a life feeling, and animating the uv offset may be worth it :wink:
1 Like

Thanks @Vinc3r :slight_smile: It is not my file - as I pointed out above, it was created by Grant Abbitt, and the textures are all hand-painted so not tileable. I had the same thought about animating it :wink:

The files are exactly as Grant gave them to me - and I think the textures are a little bit large. But his files - so I minimized any changes (basically renaming all the “cubes” so I knew what was what. ) .

Just meant to show him what could be done - though he has a whole collection of low poly stuff that he made for the Atlas Empires game that will be coming out sometime between March and May.

Atlas Empires video.

And I get old - just me trying to encourage young guys :slight_smile:

cheers, gryff :slight_smile:

1 Like

Erf ok i was misreading indeed (i’ve understood that’s you’ve made this scene following a tutorial from Grant :eyes:)

I have now added a little music to the first link. Mr. Abbit seems pleased.

@Vinc3r : don’t worry. I used his tutorials to try to figure out what was going wrong (I was having to Shift + Left Click to select objects :upside_down_face: and trying to figure out where stuff was hidden. Blender 2.81a solved most of my problems though. I must have picked some real buggy downloads :frowning:

cheers, gryff :slight_smile:

LIKE! “Hand-painted” is great. Thanks for sharing @gryff.

@aFalcon : NP. It is interesting to watch his hand painting tuts.

cheers, gryff :slight_smile:

Cool, I saved a link.

I’ve been following an artist named goro fujita on instagram,

really like his low-poly (quick to create) animations…

… would love to do something like that in BJS someday.