Activating Bloom disables AA?

Hello Forum :slight_smile:
In my Playground I enable the Bloom effect via the defaultRenderingPipeline by pressing a button. But when it activates, the fxaa gets deactivated. There was a similar question/problem here, but i could not find a solution for my problem there… :confused:

The Bloom Toggle happens almost at the very end of my Code…

The solution of the other Post:

But i dont have a BloomInstance. Instead i just use the Bloom feature of the default Pipeline…

I am grateful for any Help!

Actually, it’s the volumetric lighting post process which is missing MSAA: add godrays.samples = 4; to fix the problem.

Thank you, that works! But it is strange… if I just don’t use the bloom effect, the AA stays on :smiley:
I am relatively new to Babylon, maybe I lack the basic understanding of the workings of BJS.

Adding the bloom can change the order of texture creation/use, and the texture with MSAA should be the very first one in the post-processing chain because it is the one we render the scene in. Honestly, I haven’t looked into the details of why MSAA should be enabled in the volumetric lighting post-process :slight_smile:

1 Like