PostProcessing - chaining VolumetricLightScattering to DefaultRenderingPipeline

Hi all,

i have yet another question, this time about Postprocessing and the order.

My setup includes by default the DefaultRenderingPipeline because of the FXAA. In a current project I want to add the VolumetricLightScatteringPostProcess. The problem is, that the FXAA of the DefaultRenderingPipeline is getting ignored.

Next thing I tried is to use the PostProcessRenderPipeline

I’ve also tried to add it in front of fxaa on the render-order.

Is it possible to add the VolumetricLight AND fxaa (either with the DefaultRenderingPipeline or as a single FxaaPostProcess)

Thank you!

adding @Evgeni_Popov

In your first PG, fxaa is not enabled (see line 120): if you enable it, it does work => checked with Spector.

In your 2nd PG, fxaa does work => checked with Spector. Note that you don’t need to create a post process render pipeline, you can remove line 42 and 45.

Thanks for the reply!

It may be “on paper” that fxaa is enabled in the first example (if i set it to true) but in “reality” it looks nothing like fxaa enabled without VolumetricLight. There are hard pixel edges and you can see it clearly on the rotating shaderball.
The VolumetricLight post process seems to leave a poor resolution compared to the original render output that the DefaultRenderingPipeline has no chance to clear up the mess :smiley:
I hope you can see what I mean

Thank you!

You can use MSAA instead of FXAA to improve things:

1 Like

this… this is… this is so beautiful