Anti-Aliasing effect not working with OIT

Hello everyone,

I’m aware that OIT is still in beta and the documentation states that some Post Process effects might not work, for now. The documentation also states that we should report any issue we found with the PP effect. For my use case, the AA is not working at all with OIT enabled.

I wonder if this is a very difficult fix, we are in need of OIT + AA. Is there a known workaround for this at the moment?

I’ve created a small sample with Playground, just toggle the checkbox and check the green sphere (AA/NoAA are more noticeable there)

glTF Loader Demo | Babylon.js Playground (babylonjs.com)

Thank you for the assistance!

Pinging @CraigFeldspar the author of OIT, I’ll add AA as a known limitation, thanks!

1 Like

I think the OIT is rendering to textures for the layers so you would need to turn up the sample count on each texture to get MSAA if that’s what you’re trying to do…

If you scene is mostly not in constant motion you could use a technique like temporal anti-aliasing as a post process step also.

Thank you for the advice!
I’m sorry if I wasn’t explicit enough, but I’m trying to use TAA method as a Post Process step.