Application is Damaged when opening Babylon Editor Mac arm64

Hi

I’m trying to install the BabylonJS Editor on macOS arm64. I’ve tried downloading a couple of times, but the application is allows corrupted and the OS recommends deleting.

I’m going to try the intel version now, but I thought I’d write it here.

Thanks

adding @julien-moreau the daddy of the editor.

1 Like

Having the same experience with the arm64 version of the editor. After install MacOS tells me it’s damaged and I should delete it. On MacOS 13.1 w/ M1 Pro CPU.

The intel version is running as expected.

2 Likes

@julien-moreau will probably have a look soon after the break :slight_smile:

Hey ! And sorry for the delay ! 2023 should be the year of « answer in time » for me

I’m pretty sure this happens because the built package is not signed as I don’t have any certificate at the moment. @sebavan do you think this is something we can deal with the Babylon.JS team? This also includes having a certificate for the website.

Some of my students had this issue when using their internet connection at school which uses a proxy. All downloaded versions of the editor were damaged/corrupted and or did not have access to the website editor.babylonjs.com due to security issues (certificate etc)

1 Like

Let s add @RaananW a certificate master :slight_smile:

i’ll DM you, we’ll find a proper solution :slight_smile:

As a workaround, you can run a command in the terminal: xattr -cr /Applications/BabylonJS\ Editor.app

1 Like

Do you know which attribute might be causing the issue? Or does it require deleting all?

Im not sure to understand the question :frowning:

Have no idea, I run a command and it helped

1 Like

The command clears all the file attributes attributes, I was just curious which caused the issue, might help with the final solution :blush:

:+1: yes I assumed it’d be hard to know, thanks :pray: