Babylon 'Build Project' error in Unity

Hello everyone. I am new to Unity and Babylon. When I tried doing a Babylon build in Unity, I received the following errors.

Any suggestions?

Node version : 14.17.1
Unity version : 2021.1.12f1

Hey @vsb,

Welcome to the Babylon family!

I assume you’re using the Unity to Babylon exporter?

We’ll want to bring in @MackeyK24 who’s the expert behind that sweet part of the project!

Thank you @PirateJC. Yes I am using the Unity to Babylon exporter.

Do you have typescript installed ?

Yes I have installed it. I have the following models installed

Can you bundle up project as a unity package and send to me so i can check out if it something with the project.

Otherwise its gotta be something with your NODE/TSC setup

Try installing typescript globally for the toolkit to create its JavaScript bundle

npm install -g typescript

Sorry for the delay in replying. Tried installing typescript globally as well. Still throws the same error.

Also, I have tried building other projects and it builds fine.

Can you send me this project so I can check it out ?

1 Like

Sure, where can I send it you?

SO… It looks like the [Babylon] folder was somehow corrupted. I also am using 2021.1 and updated to the latest toolkit A31.1X.

I changed all the project settings that you were getting warning about, including lightmap settings. And of course you know we DONT support the Unity canvas stuff, so that wont export to GLTF

Your test project

With these lightmap bake settings

Exported To Babylon

Looks pretty good for what it is… Maybe it was something funny with the project folder… also you need to address the warnings about various project settings… Hope that helps :slight_smile:

Hi Mackey,

Thank you so much for all your help. I will try it out on my system and let you know how it goes.

1 Like

Hi Mackey,

I tried building the project with the updated Babylon toolkit and also changed the lightmap settings as per the screenshot but I still get the same error. Is there a way to resolve the corrupted [Babylon] folder or am I doing something wrong?