Failed to build project with Babylon Unity Toolkit

Hello everyone! I am newer for Babylon!

I am studying through Mackey’s video Getting Started Video to play around with Babylon Unity toolkit.
Babylon Unity Toolkit:5.0.0 A63.1X
When I build project, there was a warning:

And failed to build project.

I’m sure installed typescript in the project root directory.

And I tried typescript 4.6.2, 4.7.4, 4.9.4, it still doesn’t work.

Any ideas?


I saw the problem, the Node Command Line was’t set.
But when I set it up, and build project again. there is a error:

Whether babylon unity toolkit and Babylon Starter Content are incompatible?

I saw this solution: And I tried two solution, but the error was not solved :upside_down_face:

Is there anything else I have to do?@MackeyK24 Thanks a lot!

Hello BobW and welcome to the Bablyon forum!

If MackeyK24 doesn’t respond here, you can try adding a new issue on the Github repository.
Issues · BabylonJS/UnityExporter (

Many thanks, @docEdub . I will try

I removed the identifier ‘TouchJoystickHandler’ in Assets/Content/Browser/InputController.ts(1737,19).
Then I added RegisterImportMeshes and RegisterAssetContainer method on SceneManager type. Wow, It works!