Babylon Editor and GLTFs

I’m experimenting with the Babylon editor and often times find that GLTF’s I load appear with a red X. Trying to force them into the scene causes the editor to get stuck with a spinner that says “Configuring GLTF”. I’ve managed to get a couple of GLTF’s to load so far, but no luck with a number of others.

Does anyone have tips or suggestions as to what can cause this behavior? I suspect something in the way the GLTF’s were prepared must be the reason. In some cases I know GLTF’s I’ve exported from Unity will include some Unity specific extensions which will cause issues, but I’m not so sure about others.

The reason for this post is that I’m looking to engage a 3D modeler to create a scene for our Babylon project and wondering if there are any considerations for him/her to take into account when designing/exporting models for consumption by Babylon Editor.

Adding @julien-moreau who is the creator of the editor.

1 Like

Hey @avonian

Basically, adding GLTF files in the editor must give the same result as the sandbox. Have you tried adding the GLTF files in the Babylon.JS sandbox to check them?

If they appear as intented, I would love that you send me (by PM for example) one of your GLTF files so I can try to debug and deploy a fix ASAP :slight_smile:

Thanks a lot for reporting !

Hi @julien-moreau, thanks for chiming in, you helped me solve it!

I noticed that the sandbox was complaining about some of the missing references, and this made me realize that I need to select all the referenced assets not just the GLTF when trying to load it.

So yea, for anyone experiencing a similar issue make sure you select not just the gltf but also the related assets (bin and/or textures, etc.).

If it’s at all possible to have Babylon Editor display the error message like the Sandbox does, that would probably be helpful for others, but for anyone who stumbles on this thread just make sure you are selecting all assets, and if it still doesn’t work, test on sandbox like Julien said.

Thank you!

1 Like

Perfect @avonian !!

I’m checking if I’m able to catch errors from the GLTF loader directly. Else, it’ll require more engineering :slight_smile:

Thanks for the feedback!