Babylon Native for HoloLens2

Currently, is it possible to build a UWP application for HoloLens 2 using BabylonNative ?

The answer might be obvious but I was a bit confused after reading the current status in Babylon Native’s Readme

It mentions that we’re able to build for UWP
But “Mixed reality powered by OpenXR on the following platforms: Win32, UWP” is partially supported."

Does it mean XR is only possible through OpenXR which makes it impossible for now to build BabylonNative to HL2 ?

When I saw this issue unanswered, I wasn’t sure if the documentation is lacking or if it’s impossible for now to build.

I’m sorry if the question sounds dumb. Thank you !

Pinging @bghgary and @syntheticmagus

The issue you mentioned is our tracking task to update our documentation. :slight_smile:

We have worked on HL2 support in the past and it has worked in the past, but progress is slow on this front.

HL2 is supported through OpenXR. I’m not sure why that indicates it’s impossible to build? I haven’t tried it recently. Do you want to give it a shot and see what happens? You must create a package targeting UWP/ARM64. We can help you out if you run into issues.

Thank you for the quick reply.

I’m using the HL2 emulator (and not a real device).
So when I build using ARM64, I get this error

When I build using x64 and provide the x64 packages (once with framework packages, another with optional packages), it gets installed but it’s stuck there

Right, you have to use x86 or x64 for HL2 emulator. Can you tell me what version of the OS and HL2 emulator you are running?

I’m running on a 64-bit Windows 10 Pro Build: 19041.329
The HL2’s version is: 19041.1106

As for the sample, I’m using the same .js scripts provided within the BabylonNative.
I’ve set the vr/ar booleans to true when building for XR.

I’m on an older version at the moment. There are a couple of issues. First, if running the debug veresion, Chakra on HL2 cannot be put in debug mode for some reason, and the code currently throws an exception. Second, there is an issue in the XR implementation with HL2. Do you mind filing an issue on GitHub? cc @syntheticmagus

Will do right away !
*Edited: Link to the issue