Babylon running at 100% CPU (even with simple rendering)

I have personally [along with other users] been experiencing egregiously high CPU rates while running even modest Babylon renders.

For example, I loaded up the “Babylon Playground”: [removed the link since there is a limit to links]
I checked my CPU usage as my fans started firing off, and saw that it was 100%. An Inspect-Element Performance Monitor showed insane levels:

I created a profile while checking Performance, as well, in case it helps isolate the issue: Profile-20210516T214722.json - Google Drive

Finally, I have a GP63 MSi Leopard 8RD laptop, so I am running an Intel(r) UHD Graphics 630, along with an NVIDIA GeForce GTX 1050 Ti, and all drivers are updated. A buddy of mine with an older Lenovo laptop is getting similar values, too.

I have been trying to adjust settings to figure this out, but to no avail. Ultimately, I am making this report, as nothing else I [or cohorts] does can seem to impact this.

My device specifications:
MSI: Intel(r) Core™ i7-8750H CPU @ 2.20GHz 2.20 GHz, 16.0Gb Ram
64-bit operating system, x64-based processor
Windows 10 Home

Both of us experiencing this issue are running Chrome: Google Chrome: Version 90.0.4430.212 (Official Build) (64-bit)

Any assistance, or fixes for this particular issue, would be greatly appreciated!

Hi @LanderZ
Can you check that hardware acceleration is enabled in your browser settings?
Also make sure it is using your GPU, and not intel graphics(cpu based)


Ah! I just turned on Hardware acceleration and it seems to have resolved the issue :slight_smile:
I will check with my buddy to see if that fixes it for them, too. Here’s hoping! I will report back if not ^.^