Blender 2.8 babylon 6.2.3 exporter animation issue

Hi All,

I have an issue when export from blender to .babylon
In blender I see right animation


but when I run it in babylon the animation is very distorted.
All transforms is applied, when I make simple animation and skeleton all is ok, but when I start to make a bit harder animation then it looks very bad in babylon


I attached archive with blender file and exported .babylon file. If
somebody can check it I would be very appreciated. Can’t upload to playground because can’t load .babylon files to playground.

I use the code for running animation

App.splay.scene.beginAnimation(this.mesh, 0, 80, true)

Thanks for any help! (140.3 KB)

Hello, : )

There are many reasons for this, at least, as I’ve experienced it multiple times.

Each time, it was because I had something mistaken in my blender file.

I have never had a complicated build export perfectly. Common things can mess it up.

So you have to be systematic and re-build things… many times.

You need to test export as you build up. To find the errors. Then avoid the mistake.

Those type of mistakes are always very sensible.
The problem is they are hard to find if you have done many different things.
So I export on every change, and find lots of surprises. : )

Avoiding is better than fixing. In order to fix such things you have to look really closely in blender at what exactly is being set. Any anomaly and it will not export correctly.

It may animate fine in Blender, but not export, because everything needs to be precise to export.

For example:

  • origin not being set can cause that type of distortion.
  • parenting being incorrect
  • weight-paint (one little pixel being off)
  • and I forget so many others.

Another thing you can do to help is to include the log file in this chat.
Sometimes that shows the error. But also is good insight into everything going on.

Anyway hope this helps,

aFalcon yeah, before write to the forum, I spent a lot of time to test different variations. I made changes step by step in order to detect where the issue appears. What I can say for now, it behaves ownself very weird, can’t get the logic.

When I make this count of bones, then an animation works fine:

When I create skeleton with one additive bone for moving all skeleton, then an animation breaks:

Tried it several times, and can’t understand why it behaves ownself so.

Anyways, thanks for help. Will be trying to fix it further.