Babylon maya exporter deformes we


i use to export fine with the plugin. Today I tried it again, but the animations were wrong (i even tried to export an old model that i already correctly exported). I did an update of the plugin, but it still is wrong.

this is my source file, my export, and my settings. I am also creating 4 animation groups. I tried exporting with the bake animation frames option on as well, but didnt work neither. Actually the fbx has already baked animations. I am using maya 2018

any ideas?export (599.8 KB)

Pinging @Drigax

sorry the source file was too big for the attachment, here it is:

@MouseOverYou thanks for the report!

I’m pretty sure its caused by this: Maya skeletal animation regression · Issue #657 · BabylonJS/Exporters · GitHub

A recent refactor of the gltf exporter exposed some issue with how the Maya exporter keeps track of joint hierarchy, I have a partial fix I’m testing now, but i discovered another issue where animation framerate seems wonky as well. I’ll keep you posted, but in the meantime, the linked build should work for you.

1 Like

thanks! ill try it tomorrow!

HI! I updated to your fixed version and the model I posted still doesnt work. I tried another model and it works (it wasnt working for that model), so i guess is something with my model?

I noticed something else:
model 1 converts good to glb animation if there are no animationgroups

model 2(what i uploaded) doenst convert good with or without animationsgroups

Hey @MouseOverYou, sorry about the confusion. The fix was a bit more complex than I expected, I should be done in a few hours, but I’ll try to test your scenes to make sure I’m properly addressing your issue.

@MouseOverYou I had to request access to your scene file :slight_smile:

Fix has been deployed to master :slight_smile:

okay thanks! i just granted you permission for the file, ill try it tomorrow again!

I think we got a fix!

1 Like

I dont know why it still doesnt work here (the deformations are still wrong. i have tried with and without animationGroups, with and without baking) :frowning:

i am manually installing Release 20191026.3

the workflow i have always used was to split the animation track into multiple animation tracks with the maya tools. name them. then create animation groups with the same length and names with the babylon exporter. and then export with the default settings.

(i am attaching my result) like i said…i am using maya 2018

thanks! (520.5 KB)

this is what I have:

I’m not sure how to debug further @MouseOverYou, are you sure that you have the latest exporter installed? The Babylon export window should show the version number in the top bar, but your screenshot cuts that information out.

I used the Babylon_Exporters.exe v1.2.1 to install the Maya 2018 exporter v20191026.3.
I imported the .FBX into Maya 2018, and exported the scene using your settings.

Everything looks good in the exported scene on my end, i get a result similar to my original test:

If i manually reinstall the 20191023.6 version, i get a distorted nightmare of the exported model, similar to your result.

Here’s a link including the original FBX, the resulting imported scene, and the before/after fix versions of the exported scene.

Can you confirm that you’re on the latest version of the exporter?

Hi! Ill be able to check everything on again on monday. but i remeber I did check if the last install was being used by maya. And it was. I didnt used the Babylon_Exporters.exe v1.2.1, beucase it was not working(i dont remember the exact message , btu it was something like “we coudlnt find any installed files”)

ill get back to you on monday regarding the version showing in maya and the message i get while trying to instll with the .exe.


1 Like


i just installed the last version ( [20191031.3) with the installer. and I still get the weird deformations.

I tried to download an old installer to get the version that worked on your end ( [20191026.3]. but the installer still gets the newest version! . You say manually installing it also gives you weird deformations.

So I dont know how to install that “working version” ?

Oh! can you try resetting the play head in maya to your bind pose frame before exporting?