Blender BabylonJS Exporter

Since the newest versions of Blender & Babylon Exporter, we have been experiencing a bunch of new issues when exporting to .babylon. Here is a simple playground showing an old and new mesh being rendered from the exporter. It seems like the normals are being randomly flipped. We’ve tried applying transforms & recalculating normals, can’t seem to find a solution that works. Any ideas?

1 Like

Adding @JCPalmer the superhero behind the exporter !!!

I guess he will need a repro model, your blender and exporter versions as well as the logs you can see when exporting :slight_smile:

1 Like

It looks like our designer got it working finally. For anyone with a similar problem in the future:

He went into the Babylon exporter settings in Blender under material properties. Set transparency mode from opaque to alpha test. And for some reason backface culling wasn’t checked by default, check that box.


I’ve been through this myself. Another one was I had Backface Culling turned on in the Viewport Shading → Options area.

1 Like