Blender OBJ Export 2.8

if i export my models (sorted in different collections) from blender 2.8 everything looks fine, only that i lose all previous position data. It kind of sets everything to 0,0,0

i tried:

  • setting the origin to the objects geometry
  • applying transform
  • setting the pivot (in an attempt of reverse psychology) to the center

i tried not exporting everything separately yet, but that would be really tedious as its about 20-50 different parts and i need to get their distance via their position vector.

Thanks for the help in advance.
I’m really impressed by Babylon so far, hope i can give a bit back to the community in the future :slight_smile:

Hello and welcome

let me summon @JCPalmer or @Vinc3r

1 Like

I never use .obj so I won’t be a big help, but you’re right there are issue about positions, and also probably right/left handed things:

A quick export with basic primitives give me, in the sandbox:

  • all objects pivot equal to [0,0,0]
  • a x-mirrored version of my scene (even by testing other forward axys during exports)

1 Like

It is not immediately obvious from the title what format is being used to export from Blender 2.80 - so I ran a couple of tests. See the image below.

Part A: my test Blender 2.80 file. Monkey head selected and the transform data .
Part B:The .babylon file exported from Blender 2.8 with version 6.1.2 of the babylon exporter and viewed in the sandbox. Transform positions agree with Blender.
Part C: file exported as .obj and loaded into the sandbox. Position of monkey head - all set to 0.

So is the issue with the .obj exporter in Blender 2.80, or with the sandbox .obj importer?

Like @Vinc3r, I don’t use the .obj format very much, and always use @JCPalmer’s Babylon exporter.

cheers, gryff :slight_smile:

1 Like

That might be it. I exported using obj as its usually the MO when using a new engine for me. So, is there a way getting those coordinates in obj? As i’m usually not fond of switching to some pseudo export file system. Not that anything is wrong with .babylon exports. Just then its Better-Collada for Godot and fbx for unity and unreal …
Also there is that problem that babylon just spit out a bunch of errors on me. i don’t know why, i didn’t gone through them yet so maybe its something minor, but obj on the other hand :smiley: worked just fine, if it weren’t for the lost transforms…

I might try glTF next :smile: again don’t wanna bash Babylon, but opting for a more general known format anytime.

You definitly should check out gltf format, which is the already-existing file format made for realtime: GitHub - KhronosGroup/glTF: glTF – Runtime 3D Asset Delivery (you’ve mentionned Godot, they’re talking about it back to 2017 ;)).

well glTF would be nice if it would export :confused: and even if i let everything (even the stuff i didn’t select) it exports with some really weird textureshifts :confused:


that said, this might go a bit more on the blender orientent side of the problem…

Quick Update:
(sorry for the double post)

I tried importing the obj into Godot to test what @gryff stated and … yeah its basicly blenders obj export that loses all positional data as it seems. It ignores entirely every pivot which now is at global position 0,0,0 … question is: is that a main thing of obj, so it lacks capability to store information about seperate objects, or is it some problem with blender… but for BabylonJS i think there is everything fine.

Still having problems with Gltf and Babylonjs exporter, so … im trying to find a way around that i guess.