Converting to WebXR lands on a blank screen

I’ve been having some trouble with babylonjs and noa; i basically just added the createDefaultXRExperienceAsync with an arbitrary floormesh and expect to at least see myself in the environment, but when I click the VR button, it spends forever loading and then goes black, even though the camera should just be in the same position and the transition should theoretically be seamless.

This is the commit, to a minecraft built in noa: Comparing 4c536718d4acf619a02f25cf118a62195838d26f...6655e42ad7544f2ad04d69a96590812f101e8c72 · Divide-By-0/opcraft · GitHub

It’s basically a 1 line diff, where I just add-on the VR.

Adding @RaananW our own XR expert :slight_smile:

Please bear with him for the delay as he is in vacations until next week.

OH man ok – if anyone else wants to see a demo of what I’m talking about, see this local tunnel of opcraft: OPCraft

One thing that is not copied from the original camera is the height. The height is set by your VR device, so that might be the issue here, though I don’t want to rule out any other issues. I tried loading the demo, but the ngrok tunner seems to be disconnected. any way to reproduce this?

If you just go to that repo and check out the commit I linked, it’s only 4 commands to run it on your browser. You can make an ngrok tunnel to your headset like I did then, or directly access the IP your favorite way. I can also put up the tunnel again if that’s too much work!

Sorry for a late reply.
I tried looking in the project. I’m happy you have such a large project, but it is really hard to get started with it.
If you want to reproduce your situation somewhere else or with a single proejct, a web client that needs no backend and shows the issue instantly, I will be able to help you debug. Otherwise, i’m sorry but you will have to be more specific in describing the issue.