Depth rendering incorrect when using CustomMaterial?

I have a basic GLTF model that I’m using a CustomMaterial on. It looks like applying this material, without even modifying any of the shader parts, causes depth to be rendered incorrectly. Any thoughts on what’s going on here?

Fixed by setting the material’s transparencyMode from undefined as it is by default for CustomMaterial to BABYLON.Material.MATERIAL_OPAQUE.

2 Likes