DepthPeeler & transparent GroundMaterial


I think I just found a bug, that I feel not capable to solve.
Here is a PG:
Please just set the material opacity to 0.5 to activate the bug. It shows up in the console.

You just need to actiivate order independant transparency as well as a ground material with opacity != 1.

Have a great day!

Only the standard and PBR materials are compatible with OIT, not the materials from the material library (as is GridMaterial).

I see, so if I have such a mesh, how can I disable the depth peeler for this mesh only without loosing the transparency?

It’s currently not possible, but this PR will add this functionality:

Once it’s merged, you can exclude a mesh from the depth peeling renderer by doing scene.depthPeelingRenderer.addExcludedMesh(mesh):


Great news!

Thank you, as always, for your quick and precise answers.