Disable Vertex Normal Shading For Material Plugin - Faces appear as black

So, I am working on making an option for Divine Voxel Engine to use Babylon’s built in materials. And so far it is going pretty all right.
But I am having a problem with the faces with negative normals or normals facing away from the light appearing totally black.

You can see here it looks fine:

But then looking at it from the west it appears all black:

The nomrals for the west are set to:

normals.push(-1, 0, 0, -1, 0, 0, -1, 0, 0, -1, 0, 0);

Is there something I missing here? Is there just an option I can disable to get rid of the vertex normal shading?

The light is set to be:

 const light = new BABYLON.DirectionalLight(
  new BABYLON.Vector3(-1, -1, -1),
 const shadowGenerator = new BABYLON.ShadowGenerator(1024, light,true);
 shadowGenerator.darkness = .3;
 shadowGenerator.usePercentageCloserFiltering = true;
 shadowGenerator.usePoissonSampling = true;
 shadowGenerator.filteringQuality = BABYLON.ShadowGenerator.QUALITY_MEDIUM;

Thank you!

All right never mind found the solution lol.

material.emissiveColor = new BABYLON.Color3(.2,.2,.2);

Looks way better now.

1 Like

I love when I follow the error on a thread up to resolution :slight_smile: btw, love your project !!!

1 Like