Ease Zoom & Clipping when using Default Camera in Sandbox

I was going some test exports without a camera, and showing in sand box. It might just be an issue with me, but I now always use meter scale for webXR capability. Trying to Zoom clips much earlier than I want, & the increments of zoom are way too high. Maybe back off a little. I could do my own camera, but starting to defeat one of the reason for sandbox.

Not sure to get the problem. Can you elaborate?

minZ too high, & wheelPrecision too high or low.

Still not close enough & one mouse wheel ‘click’ either hides part or you are on the complete other side. I want to get close

Sure but can’t you change camera.minZ ?

Yes, I forgot about inspector. MinZ is changeable, so could set to zero. The only settable I found to get closer is FOV, which is very distorting. Things in meter scale are tiny. The mouse wheel is uncontrollably wild.

You should be able to also switch the wheel precision
If not I will add it

I opened up all the sections, and found the stuff in controls. I have ultimate control with the radius setting. They all have human titles, not wheelPrecision. I monkeyed with all of them, but none of them slowed down the amount of zoom per click. Looking at one of my scenes, I think that was wheelPrecision.

One other curious issue with sandbox and cameras is the fact that when you have multiple cameras, the sandbox ignores which camera is the “active camera” It just uses the first camera it finds (the last camera added). Not a big deal as I can change the active camera in the inspector - but I did waste a couple hours recently thinking that Blender was screwing up.

cheers, gryff :slight_smile:

That should work actually. Are you sure that the babylon file contains the definition of the main camera?

What kind of camera do you have? For arcrotate it should be in controls/wheel detal percentage

@Deltakosh er … yes.

“cameras”:[
{“name”:“Camera.Gate3”,“id”:“Camera.Gate3”,“position”:[-1.574,2,17.685],“rotation”:[0,-3.1416,0],“fov”:0.8576,“minZ”:0.1,“maxZ”:300,“speed”:1,“inertia”:0.9,
“checkCollisions”:true,“applyGravity”:true,“ellipsoid”:[0.2,0.9,0.2],“cameraRigMode”:0,“interaxial_distance”:0.0637,“type”:“UniversalCamera”},
{“name”:“Camera.Gate2”,“id”:“Camera.Gate2”,“position”:[0,12.8122,3.7229],“rotation”:[0,0,0],“fov”:0.8576,“minZ”:0.1,“maxZ”:300,“speed”:1,“inertia”:0.9,
“checkCollisions”:true,“applyGravity”:true,“ellipsoid”:[0.2,0.9,0.2],“cameraRigMode”:0,“interaxial_distance”:0.0637,“type”:“UniversalCamera”},
{“name”:“Camera.Gate”,“id”:“Camera.Gate”,“position”:[0,2,-28.6572],“rotation”:[0,0,0],“fov”:0.8576,“minZ”:0.1,“maxZ”:300,“speed”:1,“inertia”:0.9,
“checkCollisions”:true,“applyGravity”:true,“ellipsoid”:[0.2,0.9,0.2],“cameraRigMode”:0,“interaxial_distance”:0.0637,“type”:“UniversalCamera”}],“activeCamera”:“Camera.Gate”,

Above is from from the camera code in the .babylon file. And the image below is from the sandbox inspector
a_sandbox

Camera 3 was added last and is first in the Camera list.

cheers, gryff :slight_smile:

Unfortunately, the correct parameter name is “activeCameraID” not “activeCamera”

1 Like

@Deltakosh : and it does :slight_smile:

I changed the code in the .babylon file. So it is an issue with the exporter I was using “5.4.0”.

cheers, gryff :slight_smile:

1 Like

@JCPalmer and @Deltakosh : The same issue seems to exist in the “6.0.x” series of the exporter for Blender 2.80. Latest I have is 6.0.11

cheers, gryff :slight_smile:

Changed for 6.1

1 Like