Editor V4 windows compatibility


I have a slew on similar issues on three different windows 10 machines, that include:
1 - the developer mode toggle wont stay on. Does on mac, but I don’t own a mac.
2 - scripts are attached to objects but a simple console.log in update wont work.
3 - there is still this warning after every windows machine, at load, play or generate, in the editor console:

c:\code\babylon\empty>node_modules/.bin/tsc -p ./editor.stconfig.json --watch 'node_modules' is not recognized as an internal or external command, operable program or batch file.

@julien-moreau, do you confirm it should work all right under windows?

Hey @schlorraine,

I’m on it and I have some ideas. If you go to the workspace’s folder and open a terminal then type “./node_modules/.bin/tsc -p ./editor.tsconfig.json”. does it work?

I can see in the current code that the “./” characters are missing in the command


Do you confirm that once you installed NodeJS the “npm install” command was successfull ?

Hey @julien-moreau,

  • Yes, ./node_modules/.bin/tsc -p ./editor.tsconfig.json executes.
  • In regards to NodeJS and the npm install warnings mentioned here: Editor V4 FPS template , nodeJS re-installation does not help, I still have the warnings, but only on one of my three machines.

Thank you for your awesomely fast support!

Just added the dependencies in the package.json of “module” and warnings disappeared :slight_smile:
Thanks for reporting, you can now pull “release/4.0.0” :slight_smile:

@julien-moreau, all errors are gone until… the editor terminal. I appologize, it’s my mistake. I tried your command line in powershell, not cmd. For cmd, the syntax is: .\node_modules\.bin\tsc -p ./editor.tsconfig.json

I tested both / and \ and it worked here, I guess it’ll work with you as well ^^
I prefer keeping / because all other platforms use these /

OK, issue fixed: edit->preference->common->terminal path, change to powershell.
It does fix all issues.

Merci @julien-moreau!

Tu gères !!
Anyway I fixed usage of win32 to always use .cmd files. This will work either with CMD.exe (which is the one by default)