Editor V4 FPS template


I cannot get to V4.0.0 - beta4 to work with FPS nor TPS template.

It seems like its all good, then the editor closes, and reopens on this:

If I press “play”, I have the player opening all black with a sad face in the top left (same as above).

If I open in the browser its all good.

I uninstalled and re-built the editor and all but it does not change anything.

When opening a project created without template, I have the following log:

Any clue?

This one is for @julien-moreau I guess.

1 Like

Looks like the WebGL context crashed on your machine :frowning: Can you go to the main toolbar -> View -> Enable post-processes to disable the checkbox. Then save and restart the editor. Maybe there are too much post-processes. By default, SSAO2 and Default Rendering Pipeline with image processing are enabled.

Also, I haven’t noticed it in the documentation (available here: Editor/doc.md at release/4.0.0 · BabylonJS/Editor · GitHub) but NodeJS is required to build the game (Node.js). Or, if you have already installed it, the command “node” must be available in your terminal. (Node must be set on PATH)

Thank you @julien-moreau for you reply.

I did what you asked:
1 - nodeJS was and is installed and node is available in my terminal.
2 - I did uncheck post-processing and it loads until I move, as seen here:

Also, this may be unrelated, but I have a whole bunch of warnings when launching npm, as seen in the attached file. npm install log.zip (813 Bytes)

You will note the “node_modules_ is not recognized as an internal…” in the console. I have same issue with all scenes.

I checked and I have react 16.13.1 installed.

I tried uninstalling, reinstalling etc… Same results.

Any idea?

Is there a log file somewhere?

Ok, so here is a partial answer:

  • Webgl crashed in Babylon editor when using integrated GPU. For reference one is Intel UHD Graphics 630 et 620. Issue went away when switched to discrete graphics.

I still have the errors when npm install, though.

Update: npm install errors solved by @julien-moreau with latest beta release. Merci!

Ok just found the issue!!

On Win32 environment I forgot to add “.cmd”. I finally reproduced the bug and fixed using CMD and PowerShell. I’m releasing a beta asap.