Enable image processing jagged

I have a scene PG
The model with imageProcessing turned on has jagged teeth, which will seriously affect the display effect at present, and I hope to modify it.

This has more to do with Declare defaultPipeline than imageProcessing
To avoid this to some extent, do

defaultPipeline.fxaaEnabled = true;

If aliasing is the problem, you can also enable MSAA: defaultPipeline.samples = 4.

1 Like

The switch is turned on by default, and the scene effect changes. What is the reason?
how can remove

That’s because when image processing is off, it renders directly into the canvas, which in the playground is configured to use antialiasing (so, MSAA is enabled).

When image processing is on, it uses additional render targets internally, and by default MSAA is off for these render targets. You can enable it by doing defaultPipeline.samples = 4 (or any value up to engine.getCaps().maxMSAASamples).


I need a PG to show how to remove.Thanks to you!

To set max MSAA for the default render pipeline, do defaultPipeline.samples = engine.getCaps().maxMSAASamples.

If you want to disable MSAA, do defaultPipeline.samples = 0.

What I want to ask is how to keep the effect after turning on the image post-processing instead of anti-aliasing

Which effect do you mean?

image Processing



Is this not what you want?

Do not add a white mask when the image processing switch is enabled

That’s because the clear color must be converted to linear when using the default render pipeline:

1 Like