Error on using standardmaterial (3ds max export)

Hi There,

I’m having some issues here.
At the moment I’m working in max 2023, when exporting my model (just one plane from my scene to test with a standardmaterial applied to it I get the following error:

Also when using this in my own build:

Any Idea what this can be?
If I replace the material by a PhysicalMaterial the export works fine, and the model is loaded.
Also the gltf material in 3ds max throws the same error here

The left material (PhysicalMaterial ) here is working: (the others are not)
The material is plugged into a shell material here to be able to render again with the original materials.
But that’s not exported with the BJS exporter (I also tried with just the materials PhysicalMaterial/StandardMateria/GltfMaterial)

Thanks for the input/ideas

cc @Guillaume_Pelletier

do not have any issue with the materials

However for any reason, i do not have scanline/standard material anymore in my Max2023.
so i tested with 2021 and it’s work. I have to find why i do not have the scanline menu.

***EDIT ***
Re-installed 2023, got access to the scanline renderer…
Using this scene (625.2 KB)
I have the following GLB result (476.3 KB)
If you can play with the scene and modify to reproduce your issue, that will be great.

Thanks, when copying some elements from my model into a new file and replacing the physicalMaterial with a standard again this works…

Have to do some more testing to see where the issue is.

1 Like