Export & Run button is grayed out in Maya Exporter Plugin

I am new and super grateful for this tool. I was able to run through the docs and export some basic scene tests using the Export and the Export & Run feature.

However, for some reason I am only able to use the Export button. The Export & Run button is grayed out. Any suggestions on resolving this issue?

I am using Maya 2018 on Windows 10.
Babylon Maya Exporter Version v20200813.4

Hello and welcome!
adding @PirateJC

Hey @okhowdy - Welcome to the Babylon Family!

Not sure how much help I’ll be, but I’ll certainly try.

I just tried the 2019 version of the exporter with Maya 2019 and can confirm that both buttons work with the .babylon, .glTF, and .glb file extensions.

Since you’re running Maya 2018, you should be pointed to the 2017/2018 version of the exporter. Can you confirm that’s the version you have loaded in your plug-in manager?

Thanks for taking a look!

Yes, I am using the 2017/2018 version of the exporter.

It does seem odd that it worked before and now stopped working. It’s a very minor inconvenience, just wanted to make sure I wasn’t breaking it somehow. I am just grateful for such a well documented and thoughtful tool overall.

1 Like

Super glad that it’s been helpful for you so far. And sorry that it seems to have broken. It’s strange that it worked before for you and doesn’t seem to be anymore.

I’m in way over my head on this, but nothing changed with your browser preferences or security or anything like that did it? Since the export and run button talks with your browser, perhaps something in that realm might have messed with the communication between the two?

Sorry I can’t be more helpful!

Thanks for taking time to look at my issue!
I think I resolved it! The problem was between my chair and my keyboard.

TL;DR: Export and Run only works on the first instance of Maya you have open. If you initiate a Export & Run in a single instance of Maya, it seems to lock that feature to that instance. I needed to close out all instances of Maya. Reopen the file and use the Export & Run Feature.

To test:
I close out all open instances of Maya
Open Maya > Create cube > Set File Name > Export & Run
The Export & Run button is available and works.

If I Open a second instance of Maya, The Export & Run button is gray/disabled.
If I close out the first instance of Maya and leave the second instance open, the Export and Run is still gray.
I needed to close out all instances of Maya, particularly ones where I had used the Export & Run feature. Then only set up one instance of Maya where I am using that feature.

1 Like