Maya exporter wont export textures

#1

Im on a diffrent workstation and on this one the maya export refuses to export textures.
As soon as i plug in a texture i get an error message. I tried diffrent sahders and diffrent textures.
Even if i try files that worked on a diffrent workstation.

Everything is the same im using the same maya version and both are win7 workstations.

Here is the error message.

0 Likes

#2

Can you share the version of Maya and version of the Babylon exporter you have installed? Also, are the files you are using local to the machine you are working on, or are they on a share?

0 Likes

#3

Im using maya 2018.3 and the latest version of the exporter. The asset is just a cube with a lambert shader. Everything is local on my workstation.

Do you need a maya scene.?

Thanks for jumping in.

0 Likes

#4

Here is a video what im doing.

0 Likes

#5

I tested now the exporter version for maya2019 and i get the same error.
Im not able to export textures on this workstation.

0 Likes

#6

Thank you for the video, that helps a lot. I can’t reproduce your issue locally, so I am doing a little more digging into what may be going on. I’ll ping back asap.

0 Likes

#7

Many thanks. Let me know if you need anything i should try.

Looks like it does work with glTF.
But still not with babylon files.

0 Likes

#8

Hi @oglu,

I tried following the video to reproduce your issue on Maya 2019 and 2018.4 as well, but to no avail.

You mention that this works on another Win7 workstation, most likely there’s a difference between how these machines are configured that’s causing the issue.

A few suggestions I can think of to try fixing this may be:

  1. If possible, try updating your Maya installation to Update 4:
    Where to find Updates and Add-ons for Maya | Maya 2017 | Autodesk Knowledge Network

  2. Check to see that your machine has the latest .NET runtime environment installed. The Maya2Babylon exporter targets framework version version 4.6.1:
    Download .NET (Linux, macOS, and Windows)

  3. I can also see that you have Maya2Babylon version 1.2.30 installed, but reinstalling the Maya2Babylon exporter using the latest version on the Babylon Exporter repo couldn’t hurt either:
    Exporters/Maya2Babylon-1.2.31.zip at master · BabylonJS/Exporters · GitHub

Hopefully one of these suggestions help you get your machine in working order.

1 Like

#9

You are my hero.
Installing the NET framework fixed it.

We should add that info to the maya exporter Docs.

Tripple thanks with sugar on top!

0 Likes

#10

@drigax please update the Doc to mention that point:)

0 Likes