Firefox and havok on android

i’m unable to run my own havok/babylonjs app on firefox on android and a few of the examples also don’t work, comes up with a wasm compiler error.
obviously i’m probably fairly unusual using firefox on android
ps thanks for the great work your doing with this project, i’m having a lot of fun

cc @eoin and @Cedric as it might be due to some unsupported features on this platform ?

It looks like the error on old Safari. It was unsupported SIMD instruction. Updating Safari/iOS fixed the issue. I guess your browser is a bit old @peterainbow ?

don’t know what version of firefox is, it’s whatever the latest is for my phone from the play store
according to it’s about
119.1.1 ( 2023-11-09 )
so probably not that old
if anyone fancies installing firefox on android and trying out one of the many playgrounds that use havok

eg an amusing beer pong test

fails with error at (9,6495) wasm validation error: at offset 345: bad type

I’ve just tested on FF 119.1.1 and everything is fine

on android, if so which android version and i guess phone
note it works fine on firefox on my PC

just tried theplayroom lol
fine on PC/firefox
on phone bunny and arc shows, but nothing else appears and it doesn’t respond to kicks
i’m guessing the bunny and arc and button are setup in GUI or elsewhere and that the physics is failing ( no error though )

btw it’s a moto g6play on android 9 that it doesn’t work on
however just tried it on a mui phone with android 12 and it works fine

so looking like it’s about android :frowning:

grrrr, so guess an extra corner of a corner, feel free to ignore, not that anyone is actually going to play with stuff, just bored and unemployed…