WebXR No Longer Working in Preview

Just in case this has not been documented yet.

Babylon.js Playground for example does not work anymore. Tried with Emulator in Chrome and in Oculus Browser.

Reverting back to CDN works but doesn’t have the particle fix :frowning:

Adding @RaananW (Don’t hold your breath as he is OOF)
Maybe @syntheticmagus can help in the meantime

@Michael_Prosser do you know when was the last time you have seen it work ?

Not completely sure but I did manage to find a copy on local server Babylon.js v5.0.0-alpha.24 which works awesome.

Actually I had it working yesterday using preview come to think of it. Hopefully that helps.

So it would be latest only @Evgeni_Popov could you double check your rtt on camera code or we might need to revert it ?

I know nothing of XR, I don’t even know how to test it…

So it’s probably better to revert the code and wait for @RaananW return.

I can test XR stuff if it is any help. One problem on the mobile version of PG is that you can’t select a version (or at least i don’t know how to) but i can download and test on a local server so could specify versions to find out when it broke. But when is Raanan back on deck, should we just wait for that?

Edit: i have figured out how to change versions on mobile PG.

I ll make a custom build by reverting the change tomorrow so you could test it.

As @RaananW is off for 3 weeks, it would be better to come back to our previous state.

@syntheticmagus I ll ping you on Monday to double check what we are doing :slight_smile:

1 Like

Fix in progress should be deployed in about 1 hour. Sorry for the inconvenient guyz but it was a bad idea to push it before the 4th of July :slight_smile:

Ok So nightly is deploying as we speak and should hit the server in 30 minutes top

1 Like

@sebavan I just tried with the latest version 5.0.0-alpha.30 and it is still not working? Is this the one with the fix or was i too early and should try later - i tried 30min after you indicated it would be live.

I updated one of the other threads before i saw this so updating here to keep it on one thread.

Everything is working back for me on this playground: https://playground.babylonjs.com/#TJIGQ1#3

Be sure to force refreshing the cache the deploy has just finished 10 min ago.

1 Like

Yes working now after clearing cache. Thanks.

1 Like

Thanks for seeing to this :slight_smile:

1 Like

I’m catching up right now - seems like this was resolved by reverting the changes in the render function, right?

Yup, basically let s check offline with @Evgeni_Popov cause the previous change attempt completely broke the rest of XR.

1 Like