Glb export from maya produces extra overlapping vertexes when imported to blender

The mesh that I have in Maya has 1015 vertexes. When I export it as glb and import it into Blender the number of vertexes increases to 3884. These extra vertexes overlap on top of each other and if I merge them in Blender then I get the same 1015 vertexes. The merge vertexes in importing option don’t do anything.
In the same Maya file I have other meshes that export and import correctly.

Hello and welcome to the Babylon community! As this question is related only to DCC tools I moved it to the proper category :slight_smile: Unfortunately I have no experience in Maya but I’m sure someone here will be able to help.

1 Like

I know the exporter in question was recently “de-commissioned”, see No Longer Actively Supporting Autodesk Exporters.

I never ran maya, but I did a few GLB imports off that exporter into Blender, specifically @PatrickRyan’s XR hand meshes, and I did not notice that. The hands actually had many fewer vertices than I could have done on my own. This was accomplished by shipping tangents. Tangents are imported to Blender as this “Split normal stuff”, which is not all that normal :grinning: for building stuff in Blender.

Do not know if the issue is between exporter or Blender, and not sure it matters any longer. Recommend, that you double check with everything which you are moving to Blender.

@Alahazrat, what you are likely seeing is an unoptimized export from Maya. The Maya exporter has an Optimize vertices option that should be checked as you see below. If you don’t optimize the vertices, the mesh will bloat since we skip the optimize step. This option is there because if you are doing a quick export to test, this option exports much faster. But if you are exporting your mesh as final or to go to Blender, you want to make sure you have checked Optimize vertices. Hope this helps, but let me know if you have any other questions.