Glow layer turned on selectively?

Hi all!
I’m wondering why my glow layer gets turned on for meshes that don’t have the glow layer material applied to it? Seems that it’s turned on for any material that has an emissive color set? Can i set an emissive color for a material and not have the glow layer turn on for it?

In this PG, i’m looking for:

  • Sphere 1: wrapped in an image material with emissive color set (but don’t want the glow)
  • Sphere 2: glow layer


By default, the glow layer applies to all meshes. You can include or exclude meshes, see doc: Make Mesh Glow - Babylon.js Documentation

1 Like