Ground shadows in AR

So I’ve been trying to get ground shadows to work in AR and I thought a mesh using a ShadowOnlyMaterial would be the way to do it but so far I cannot see any shadows.
Here’s a playground example: https://playground.babylonjs.com/#KDWCZY#246

Is there another material I could use to recieve shadows only? Or is this an issue with the shadowgenerator settings?

Hi! and welcome to the forum.

This demo does a lot - anchors, hit-testing and plane detection (the last one being a non-standard feature that requires the incubation flag). Maybe first try hit-test only, with a simple ground underneath the object. Give the ground a shadow-only material, and make sure your light and shadow generator definition fit your scenario (i.e. - positioned correctly and in the right direction).