Hand Tracking Not Showing as Available Feature

I’m trying to test hand tracking on Oculus Browser with my Oculus Quest 2. I’ve enabled the webxr-hands flag.
When I run the following playground (https://playground.babylonjs.com/#X7Y4H8#16) on version 5.0 alpha, I get the error:


I found the part of the code that was causing the error, so I commented that part out. Then when I ran it, my hands appeared. However, it seemed to me like the tracking wasn’t as good as when I’m in my Oculus home environment.

I tried to build and run this locally: I created a project with webpack and es6, similar to RaananW’s starter (GitHub - RaananW/babylonjs-webpack-es6: Babylon.js basic scene with typescript, webpack, es6 modules, editorconfig, eslint, hot loading and more. Will even make coffee if you ask nicely.), and added the following:


When I try to run on my Quest, it says the feature isn’t found:

When I console.log the available features from the FeaturesManager, I get the following:

Why isn’t hand-tracking showing up as a feature? I’m still using version 5.0 alpha locally. Thanks in advance!

As an extra note, other hand-tracking samples seem to work fine, such as this one from the immersive-web group: Immersive Session with hands

Maybe @syntheticmagus can help ? otherwise you ll have to wait for @RaananW to come back from vacation in a week :slight_smile:

Thanks for the ping, Seb! I don’t know exactly what’s going on with this, but I do repro it. Raanan will definitely be able to help once he gets back, but I’ll try to take another look sooner than that and post here again if I get more information about what’s going on.

2 Likes

Thanks a ton @syntheticmagus and @RaananW will be back next Monday so nw :slight_smile:

1 Like