Having some error in starting a basic VR scene

I am getting error in rendering a very basic VR scene in my mobile chrome browser. I use snapdragon based mobile. immersive-ar mode worked (diff app), but not the VR model.


adding @RaananW our XR guru

1 Like

I tried in few other devices and it worked fine. But not in mine. Still having that white screen issue.

I reinstalled chrome and reverted the changes I made in developer options. Now its working :slight_smile:

1 Like

I am getting the error again. When I installed ARCore services back. I guess, both the AR mode and VR mode are spinning up simultaneously in certain device leading to the half white screen. The error surfaced back only after AR Services for chrome was reinstalled.

Android supports AR mode, but I am not sure if VR mode requires extra service support. What device are you using to view the VR content on a mobile?

Redmi Note 11. Actually VR worked. But when I have ARCore installed along with Android VR Services, I am getting this bug. The white screen. Maybe both AR and VR getting launched simultaneously ?

That should never happen. VR capabilities require an external service (as you mention). I was under the impression that Google VR services is deprecated (because of the early death of Daydream), but It is more than possible that my assumption is incorrect :slight_smile:
I also assume you are using WebXR (and not the deprecated WebVR)?

I was prompted to install this :slight_smile:

This is mainly for daydream (and cardboard), i am pretty sure google doesn’t fully support this (Google’s VR dreams are dead: Google Cardboard is no longer for sale | Ars Technica). Are you using a specific headset? Straight from Redmi?

Straight from Redmi

so, this is not really VR, you are just looking for a split screen rendering?

Yea, one side shows the normal rendering. The other side is plain blank white.

I am not sure how well the VR services work with WebXR. There is sadly little we can do about it…
If you just want to see split screen you can use the stereo orientation camera, but then you lose all of the wonderful benefits of using WebXR.

I think it has to do with my device. Nothing to do with BabylonJS. Getting the same error when trying VR mode in YouTube.

Babylon is using WebXR, which is a web standard. We do little to no magic when it comes to processing the immersive session. If it doesn’t work on a specific device it is probably a hardware/driver issue. Of course, it is always possible babylon does some craziness, but we really do our best to never influence the headset init this way.

1 Like