How to reduce Jitters using anti aliasing concepts

Hey guys, using this topic Topic successfully created borer textures but the issue is with jagged edges in texture may be anti aliasing how can i reduce it is there a way i can reduce them in my node…
Node Link:
https://nme.babylonjs.com/#SID68E

The output that im getting is :

can anyone point me in right direction

3 Likes

First your scene is beautiful!

That being said, I think you are seeing this artefacts because of resolution I guess. You may want to introduce antialiasing in your shader.

Let me ping @Evgeni_Popov or @nasimiasl

1 Like

i am on it

1 Like

@sai_chaitanya

Your scene looks very nice. Are you using StandardMaterial or PBRMaterial for your objects?

hey again
@sai_chaitanya

https://www.babylonjs-playground.com/#BBL2S3#6

2 parameter is important when you wanna control “reduce Jitters”

  1. the first is depths of length
    the reason of that is gpu just calculate one pixel so when you r far of surface pixels not scaled so gpu cant smooth that the solution is calculate that and resize border thickness and make it more transparent

i calculate depths by :
line : 50

min(1.,max(0., log(0.01 *length( vEyePosition.xyz - vPositionW)) ))

and set thickness in line : 52

float brdSett = (0.9994-0.004*fresnelPlusFog);

  1. fresnel is make same effect too but i cant fix it in this sample

** the best option is use thickness on your diffuse texture that result fade better
because GPU control automatic LOD in texture2D

also when you use the postprocess for anti aliasing you not focus just on tiles so and mesh edges so maybe postprocess make a bit blur your result

2 Likes

Hey @nasimiasl the thing is im using node material instead of custom material can you just have look into the node material which ive managed to create Node Material

we are using PBRMetallicRoughness block @samevision

1 Like