Introducing Babylon.JS Editor v4.0

hey i’m trying to add 3d model, but this is what it looks like on preview

image
image

what is wrong with this?

Hi @naonvl !
That’s weird! Is it coming from a GLTF file?
Can you try to select one of these materials and change the Side Orientation parameter in the materials settings to know if it fixes

1 Like

Good afternoon. Is it planned to support javascript in addition to typescript in the editor? And support for recastjs navigation?

Hi @Lazarus_Rainhard !

For sure Recastjs is in the todolist!
But JS support is not really for instance especially because of decorators (see Exposing properties | Babylon.js Documentation). Having both TS and JS working may require a lot of code and a lot of tests :frowning:

Hello. I’m new member here. :slight_smile:

I have a question. Is it possible to make Tabs be detached from the Main Editor Window and arranged into their own floating Editor Windows ? Pretty much like UE/Unity and most Adobe product. (Photoshop, After Effects, etc…)
Example : Unity - Manual: Customizing your workspace

It would be very useful for dual/triple monitors users like me.

Thanks.

1 Like

Oh also i have request. Sorry for double posting.

Is it possible to integrate After Effects to babylon.js ?
Able to work directly in after effects and update the animation timeline keyframe in babylon js real-time would be incredibly useful :slight_smile:

Thanks :slight_smile:

Hello @Codelyoko_1 and welcome to the Babylon community! It would be certainly be awesome to have After Effects Integration! Since we’re an open source project, anyone can contribute with new features. Just need to open a Pull Request on our Github (GitHub - BabylonJS/Babylon.js: Babylon.js is a powerful, beautiful, simple, and open game and rendering engine packed into a friendly JavaScript framework. ) and the team will take a look at it. :slight_smile:

2 Likes

I tried to install the editor for macOS (4.2.0 for Apple Silicon) three times.

First time, the OS said the app was broken. On the second attempt, Chrome quit the download with a network error. Third time, the app was broken again.

I then tried 4.1.1, and it also refused to install. macOS says every version of the editor is “damaged”.

It’s also taking forever to download (like 20 minutes, instead of one or two). Is anyone else having similar issues?

2.3.0 sorta works on apple sillicon although it has some permissions problem, and fails at several taks:

I filed an issue on GitHub…

1 Like

Found a fix.

Everything works as expected when I open the app in sudo mode through the Terminal.

Nice. I can now dwelve fully.

I must say though, my Macbook Pro with M1 chip gets boiling hot like no other app makes it heat usually.
I wonder what is going on under the hood with this Electron thing…

2 Likes

Apps like Slack and VSCode use electron, I don’t know if thats necessarily the cause. Unless it’s all electron apps acting like that

Hi @wwwonka @br-matt !

I think the M1 chipset becomes hot because by default the SSAO2 post-process is enabled in the Editor with some kind of “maximum quality”. If you disable SSAO it may be better.

Do you have a M1 MAX ? My M1 MAX is not hot when I set 16 samples for SSAO 2 (instead of 32 samples)

2 Likes

Yes @julien-moreau, I am lucky enough to be on M1 Max as well.
I’ve reduced de SSAO of the scene to 16 samples as you said.
At first glance, it seems better.

Is there a way to reduce the FPS to 60 as well? The 120 FPS is neat but maybe uneeded for building stuff, this could maybe improve things as well

… I will be scaffolding a little project in your mighty editor in the next few weeks to give it proper test run, I will give you feedback on how the temperature behaves! :melting_face:


After giving it more taught, just like @br-matt pointed out, it made no sense that Electron was the cause of the high temperature. Slack, Spotify, VS Code and even Chrome for that matter never made the laptop go hot.

My experience has been that WebGL scenes often make phones almost melt. Since these new Apple sillicon chips are sortof big iPhones processors, it makes way more sense that WebGL makes the computer behave kindof the same.

One clever solution to overcome this that I knew from back when I was doing stuff with three.js was to fire the animation loop only when needed as this guy did:

Basically: render the scene only one frame when possible and start the animation loop when interracting. That way, I remember that the performance of my webpages would drastically improve and keep devices cool.

This could be a neat optimization for the future of the BJS editor;

just a suggestion!