Introducing the GUI Editor Alpha!

Hey @renman87 currently this is out of scope for v1 of the editor. Granted this is something I can see us implementing in later versions if the community wants it :smiley:

@msDestiny14
I have the same error.
If I test from the link : https://gui.babylonjs.com/ It works.
But if I use from this link to test in local, I get this error :
Babylon.js/guiEditor/public at master · BabylonJS/Babylon.js · GitHub
The error occurs locally because GUIEditorNodeMaterial.json cannot be found.
I’m assuming GUIEditorNodeMaterial.json exists at https://gui.babylonjs.com/

I am up to date, my caches are well empty.

I use :

<script src="https://preview.babylonjs.com/babylon.js"></script>
<script src="https://preview.babylonjs.com/gui/babylon.gui.min.js"></script>
<script src="https://preview.babylonjs.com/guiEditor/babylon.guiEditor.js"></script>

GUIEditorNodeMaterial.json is found with the Babylon url, but not locally.
Does this file have to be appended or is it automatically appended?

1 Like

If you a look at folders the GUIEditorNodeMaterial.json. it’s there…but it’s not finding it? I think I need to embed the node material directly inside the code. Let me see about implementing that today.

Also I’m wondering if I should default to the white background just incase something happens. I think I will add that as well. Thanks for keeping me posted.

1 Like

Yes it is. because I don’t add it to my local directory. I thought he was calling automatically. On GitHub indicate to use babylon.guiEditor.js. the hardware node is not mentioned.

It is a good idea to integrate it directly into the code. Thank you

Here we go. (Ya this was on my todo list :slight_smile: )

Should be fixed once this gets merged in and nightly.

1 Like

Hi @msDestiny14

The problem still exists, even with the changes.
I have updated fine, clearing the caches, but I still get the same error.

Uncaught (in promise) LoadFileError: Error status: 404 Not Found - Unable to load GUIEditorNodeMaterial.json
    at t [as constructor] (babylon.js:16)
    at new t (babylon.js:16)
    at babylon.js:16
    at XMLHttpRequest.m (babylon.js:16)

I’m a little confused by this since now that the node material is embedded there is no .json file anymore. Nor a place where it should be loading a file. :thinking:

Please, can you try to download the files from this link, then test the index.html file in localhost. I’m sure you will get this same error.

I use its files available in guiEditor / public / without modifying anything. I put this in a http localhost server. I open the index.html file. and in the console there is this error.

I’m also confused if you say this should be good. There must be something wrong.

Edit: @msDestiny14

Ok, the update didn’t work. look at the preview release/guiEditor/babylon.guiEditor.max.js file line 46746
(it is the only reference like that)

 return [4 /*yield*/, nodeMaterial.loadAsync("GUIEditorNodeMaterial.json")];

This is normal, the nightly has not been released so far.

I will do it in a couple hours.

2 Likes

After the nightly released, the error is corrected. Thank you. :+1:

2 Likes