Is WebXR well supported in Oculus?

I’m considering to start a project in Babylon.js through WebXR for Oculus Quest. I’m trying to figure out if WebXR is well supported on Oculus Quest. I was doing some research, and at this LINK I can read “Oculus quest using the oculus browser […] It all works (usually) without a problem”.

I would like to ask if Babylon.js through WebXR is well supported on Oculus Quest, when using Oculus Browser or another browser. I’m open to considering different alternatives, for example WebVR (but AFAIK it’s not supported anymore in Oculus Browser). My project is essentially about displaying lines and points, so it’s not particularly computationally intensive. It also requires to interacts with these points and lines through the Oculus controllers.

WebXR is the way to go.

I am testing every scene/demo I create on the WebXR emulator, a windows MR device and the oculus quest and make sure that they all work correctly. The oculus quest controllers are fully supported, and so is the teleportation feature.

As WebXR is still evolving, there are always small hiccups. We are trying to do our best to avoid those and to get everything to work always, but sometimes it is not the case. This is the reason for the (very important) “usually” keyword in this sentence :slight_smile:

And a quick note about WebVR - unless you force it, WebVR is no longer supported on the oculus quest.

TL;dr - use WebXR on the oculus quest

1 Like

Thank you very much! Then I’ll follow the WebXR route.

1 Like

WebXR at babylonJS is very easy to understand and has complete documentation (I love the playground). I have tried using WebXR using Oculus Browser and Firefox Reality. It worked well


I have question about this sentence: “[…] quick note about WebVR - unless you force it, WebVR is no longer supported on the oculus quest.”

It’s totally clear that WebXR is the way to go, but I was wondering how it is possible to force the Oculus Quest to still support WebVR?

We have a special situation where this would be very helpful, but haven’t figured out a suitable way to go. Thanks in advance for your answer!

I think there’s a flag in the Oculus Browser settings which can enable/disable WebVR support, but I’m not sure.

There is (or at least used to be) a flag under chrome://flags to force a runtime. either WebXR or WebVR. I have to admit I haven’t tested that for quite some time, so it might already be gone. I do hope it is! :slight_smile:

I can confirm it is gone

1 Like