Light texture projection and PBR?

Hi :slight_smile:

Please have a look:

I’ve just changed the ground material from Standard to PBR and the effect (talking about projection texture from a spotlight) is gone.
I had to ramp the intensity up for the light but no more projection is observed.

Is that expected ?

If it is, is there a way to have a mesh in a scene which is never visible in the viewport but has its impact on shadow to fake the projection effect in front of the spotlight?

Thanks !

The material should be none metallic I guess or you would only see the spec color component. The intensity difference comes from the light units being physical in PBR.

1 Like

Thanks sebavan,
Apparently, I misread that part

In order to setup the PBRMaterial in Metallic/Roughness mode, at least one of the following properties has to be set (else it by default works in Specular/Glossiness):


And I thought that just setting roughness would be enough. And I didn’t see a default value for metallic in the source code.

Well, it works, that’s what matters!

Thanks again :+1:

The default value for metallic is 1 in the metallic workflow if you don’t set a value for this property, that’s why you don’t see anything, the material is fully metallic. You don’t need to set metallic to 0, other values will work too (but as you approach 1 the projection is less and less visible).


Thanks for the clarifications Evgeni :+1: