Loaders not being recognized when trying to import meshes

Hello. First of all, thanks for the awesome project!

So, I’m having issues while trying to import meshes in my app. The following errors and warning are being triggered:

I’m importing the loaders that way at the file that tries to import meshes:

And my webpack looks like this:

The meshes are being imported like this:

To treat with the path problem recognizing .glb files, I’m doing like this:

Can someone please help me? It worked this way a few days before, now it isn’t, don’t know what happened. Stuck on this. Thanks!

Welcome aboard!

It’s in your package.json file that should have a look and check that the babylon.js loaders package is referenced there. In addition, it must be of the same version as the main babylon.js package.

1 Like

Thank you, and glad you replied.

They’re with the same version. Images from inside @babylonjs folder on node_modules below:


Tried to reinstall, but yet without success.

The stranger thing happening is that I can console the loader before calling import mesh function, and seems instantiated, but when rendering the errors are being triggered.

Got it! Happened to work installing babylonjs-loaders as separeted package and importing this way: