Max2Babylon KHR_texture_transform with Offset -2,2?

When using KHR_texture_transform, the exporter generates Offset values of -2,2. Should these be omitted for optimization’s sake, unless we’re using a non-zero Offset amount?

Sample (274.8 KB)

glTF excerpt:

"KHR_texture_transform": {
"offset": [
"scale": [


Adding @Guillaume_Pelletier

1 Like

Incidentally, Max2Babylon also seems to be adding an empty node called “Default light”, even though the Babylon Scene Properties has the default light disabled.

This default light is not “connected” anymore, i will ask the team if they want to support it or remove the options from the project form. You may use “No Automatic Light” from the main panel instead.