Maya Exporter- Animation Interpolation: Type mismatch. Property value 0 is not a 'string'

Hi there ran into an odd issue regarding exporting .gltfs & .glbs.

My work uses its own propertity platform, and recently the preffered format has been taking .glbs/.gltfs for 3d models.

I’ve been able to use babylon flawlessy for exporting those files on my computer at work, with Maya 2018 - no issues.

However due to corona and social distancing, I’ve been working from home. However despite having the same version of Maya 2018, and the exact same scene with the same export settings for babyblon any .gltf/.glb i export from my home computer doesn’t import into my work’s platform.

It gives me an: “Unexpected end of JSON input” error.

When uploading to gltf- viewer I recieve this: "TYPE_MISMATCH Type mismatch. Property value 0 is not a ‘string’. /animations/0/samplers/0/interpolation" all the way through to “/animations/0/samplers/148/

After checking with some developers at work and comparing two gltf with a JSON editor they’ve confirmed any .gltfs i export from my home computer have the interpolation set to ‘0’ instead of ‘LINEAR’.

Now I’m wondering have I missed a setting either in Maya or Babylon? Because i’m unsure why my scene is throwing out two different .gltf files on different computers, despite the same version of maya, and export settings.

pinging exporters master @Drigax

1 Like

Thanks, this sounds like a bug I just fixed a couple days ago via: glTF Animation Samplers exporting as "0" instead of "LINEAR" · Issue #804 · BabylonJS/Exporters · GitHub

@Happles Can you check that you’re using the latest release?