Mesh is breaking on export

I am exporting a rig with baked animation and it looks fine in maya, and the curves aren’t flipping or anything, but once it is a glb there are issues in the model, particularly the shoulders are warping. I have tried deleting the entire rig and baking in maya before exporting, and the glb looks incorrect, even though it is fine in maya. I am using babylon version 20200113.2

Same as the other issue, a repro would be nice for this one.

Ping @Drigax

1 Like

I can’t share the file from work but steps are:
-Export as glb using only selected joints and meshes, meshes setup with arnold standard shader
-glb will have warping in the animation
-delete glb
-try again, and this will fix the geo warping

I am not sure if this is because the previous glb was exported using an older version of babylon, or if something else is happening. Using maya 2019.2, windows 10

Hey @Thunda1986,

Would you be able to create a small scene that reproduces this issue? It sounds from your description that you’re seeing some distortion when exporting an animated skeletal rigged mesh. Can you try setting your scene playhead to your bind pose frame before exporting?

I can try when I have more time. Yeah I am working on animated glb’s. I can’t set the scene to bind pose because that would be baked into the animation. Did you mean set it to the first frame of the animation?

In the Animation Group window, you can choose the frame range that you want to export. You can then add a frame in your timeline where the mesh is in its rest pose, and set the playhead to that before exporting.

I created an issue to track this, this is definitely not good behavior:

2 Likes