Mesh positions in a .babylon file are different between sandbox and editor

I’m making a dramset model for template of Babylon.js Editor v4.
But the position of the model is different.

“cymbal1” are aligned as (x, y, z = 0, 0, 0)
Then all dramset model were exported as babylon format.

[Babylon Sandbox]
Uploaded the babylon file into the sandbox and checked inspector.
Then position of “cymbal1” is (x, y, z = 0, 0, 0) (Screenshot : PositionOfSandbox.jpg)

[Babylonjs Editor]
Drag the babylon file and drop it into Preview area.
Then position of “cymbal1” is (x, y, z= -7500, -3233, -4882)

I opened the babylon format file. The position seems to be (x, y, z = 0, 0, 0).

Here is the babylon format file: (89.8 KB)

My environment is the following.

Commits · BabylonJS/Editor (
commit id :f2c877ef19fc4fd2a82fba4d08e4921861a4cb42

Any comment would be helpful for me.
Sorry for bothering you.

Thanks @Limes2018 for that feedback!
It’s a bug :frowning:

When you drag’n’drop a mesh scene in the scene it can be useful to add it where it has been drag’n’dropped

Unfortunately here it is added on the skybox (reason that it is so far) and editor should check that. Here it doesn’t. I’m fixing ASAP

For now, try to disable the skybox (using the inspector), drag’n’drop you scene and re-enable the skybox. You’ll see that the meshes will be added relative to (0,0,0)


Thanks for kind reply.

My dramset model has been successfully loaded by using skybox setting.

About skybox, my project including babylon format scene sometimes generates afterimage.
when I added skybox mesh by coincidence, the issue disappeared.
(It is not easy to explain how to reproduce it, sorry)

I guess there are some issues around skybox. After published new version of editor, I try to confirm it.

@Limes2018 thanks !!
Do you mean that you removed the skybox and then re-added a new one? If yes, I have an idea of the bug :slight_smile:

Disabled skybox, drag&drop my model, and check my dragged model’position. The position is the same as one on Blender.
Enabled skybox after dragged and check the model’s position. The position was also the same. ( I think it is the same as your expectation)

Of course I can tell you more information if you need :slight_smile: