Meshes appearing transparent in Editor (v.4) when importing

Hi everyone,

I recently started using the Babylon.js Editor. I started working on the version 4.0.0-rc.3 on Windows 10 and at the beginning it was importing meshes perfectly, but after that it started importing them transparent?

I uninstalled this version and installed and tried every version from the rc.0 to rc.4, but it doesn’t work.
Also, I tried removing all the textures from 3ds max and importing them again, so I can place the textures through the editor, but it doesn’t work once again.
Another thing I tried was to change the geometry, but did that not seem to work.
I removed the material, but unsuccessful again.
Checked the exporter from 3ds max, but there are no errors at all.

Also, with created meshes in the editor this problem is not occurring, only with imported ones.

Here are some screenshots:

I honestly do not know what the problem is…is there a bug in the Babylon.js Editor…?

Do you have any advice? Did that happen to you too? I would be really glad if someone could help…

Adding @julien-moreau

Hi @sevdev !!
Thanks a lot for reporting! I have tried and I reproduced only using GLTF files:

The problem appears only when SSAO is enabled (this is enabled by default in the Editor). In your case you have 2 solutions:

  • Disable SSAO 2 by selecting the scene in the graph and go to the inspector using the tab “Rendering”
  • For each material, go to the advanced section and select “ClockWiseSideOrientation” to invert the order of triangles for these specific materials

Using one of these solutions will fix the problem:

@Deltakosh or @CraigFeldspar the editor is using BJS 4.2.0. Do you know if this problem is known or fixed in more recent versions ?

If it can be fixed, @sevdev I’ll automatically set the clock wise orientation each time a GLTF file is added in the scene in the editor.