Model with skeleton get strange flare

When I import model with skeleton into my scene, the model get strange flare.

But when I set the mesh.skeleton=null, the strange flare disappeared.

This is my project page.
https://project.veryengine.cn/publish/CdmdXJV2c/index.html

How to solve this problem?

If you disable the “interior” meshes (like tongue or teeth or so), does the flare disappear?

If so, not sure if something like emissive colors or other material properties can “shine through”? Otherwise, push back the mesh a little in your 3d software (e.g. Graph editor in Blender). Or weight painting, seeing that the left arm is raised in the first pic. Maybe it has some minor influence on the teeth pulling it forward.






I tried disable the “interior” meshes, but still get flare .

The material of model is node material. Is this problem related to the node material?

What happens if you don’t use this material? Do you have the same problem if you try to drag&drop the model in the sandbox?

Can you provide a link to your scene that we can use with the inspector (there’s a login page with the url you provided above)?

If I don’t use the material, strange flare disappear.

You can try the page again without login.
https://project.veryengine.cn/publish/CdmdXJV2c/index.html

I could not find a problem with the node material.

Did you test your model in the sandbox?

The model in different position will have different effect.
When the position is (0,0,0), strange flare disappear.

When the position is (0,0,5), strange flare appear.

looks like the normals might be wrong for some reasons is the mode ok in other viewers ? can you share a repro ?

Is the wrong normals related to skeleton exported from maya? What does other viewers means?

Like

https://project.veryengine.cn/publish/CdmdXJV2c/index.html

Through the inspector of this page, can you find the reason of this problem?

Can you provide a link to the glb file of your model?

You can use the scene.babylon file of my model and then load PIFU.json as Node Material to set the material of mesh cc_base_body to get final model.

Can you find the reason through the babylon file?

Your model uses more than 4 weights per bone, so you should also connect the “extra” inputs of the Bones block:

image

I’m not sure if it’s the problem, though, as I could not reproduce it on my computer.

I tried connect the “extra” inputs of the Bones block, but can’t solve the problem.

Could this page reproduce it on your computer?https://project.veryengine.cn/publish/CdmdXJV2c/index.html

Yes, I reproduce the problem with your page, but not in:

I reused the same assets than you and I can’t reproduce the problem. Maybe you should start from this PG and add things one by one until you can reproduce the problem?

1 Like

In playground, I can reproduce the problem when I change camera position very near the mesh.

It’s the multiplier for the roughness value which produces these artifacts, it’s a bit better if you lower it:

Current value (1.95):

0.96:

It may mean that the problem is in the metallic/roughness texture. I’m not sure, but the texture may have been authored in gamma space instead of linear space, in which case you should enable the “Convert to linear space” setting on the texture block. If you do so, with the existing 1.95 value, you get:

cc @PatrickRyan, who may have some advices for you.

@PatrickRyan What is the real reason of this problem and how to solve it?